UXO Software 7.5.0 T1 Update

July 5, 2012

UXO software (UX-Detect, UX-Process and UX-Analyze) update for Oasis montaj 7.5.0

Download from My Geosoft

Release Notes

This download provides Geosoft’s Oasis montaj software v7.5 T1 incorporating many updates and bug fixes for the UXO toolset (UX-Detect, UX-Process and UX-Analyze). There is more information on Unexploded Ordnance solutions here. This download is for UXO customers only.

What's in UXO Release 7.5.0 T1

This is a special release called a "T1" release and includes new software and improvements not yet available in our standard Oasis montaj release. This “T1” release is installed separately and will not overwrite your existing (standard release) of Oasis montaj.

There were numerous corrections and improvements to the tutorial and Help files for UX-Detect, UX-Process and UX-Analyze Advanced. The UX-Analyze Advanced tutorial is not included in the software download and is available on our Technical Documentation page.

Enhancements and maintenance fixes

Click here to view the significant enhancements and maintenance fixes included in each menu for this release.

UX-Data Preparation Menu

Menu Item Summary
Survey Layout > Plan a UXO Survey Fixed "Out of Virtual Memory" error when creating a plan using a DXF file.
USACE Instrument Tests > Static Test User was prompted to overwrite database when using different lines from same database.  The GX now saves all the records in the database and will not check if the record already  exists, and no warning will be issued. 
USACE Instrument Tests > Static Test Fixed calculation of static repeatability % response values in Access database, which often appeared too large.
Data Corrections > Instrument Drift Correction Fixed to enable the GX to run properly in script mode.
Path Corrections > Sensor Offset Corrections Fixed bug so that the input (original) X-Y coordinate data will not be altered.  The output database backup "_X_Offset/_Y_Offset" channels are also now the same as the input X/Y.
Path Corrections > Sensor Offset Corrections The Acceptance Threshold units are now documented in the help and the default value is determined using a more realistic calculation based on data that is collected while the instrument is in motion vs standing in place at the beginning of the line. The user can also change the value to help smooth more out if they choose to.
Path Corrections > Sensor Offset Corrections Added support for array channels.
Path Corrections > Sensor Offset Corrections Now allows time/date/altitude/depth and other channels to be exported to output database when applying path offset corrections.
Path Corrections > Sensor Offset Corrections The channel dropdown list no longer displays the channels twice, when you use 10 or more channels in the "Number of DB channels per sensor" parameter.
Path Corrections > Sensor Offset Corrections Corrected error that gave message "iExistSymb_DB : Invalid Symbol Name Length"
Utilities > Export Data to XYZ File Cleaned up the user dialog regarding instrument selection, and the instrument will be pre populated by default with the same instrument as the latest static calibration or export to XYZ.
QC QA Tools > Sample Separation The line path is now displayed in gray instead of black. This makes the plot much easier to read.
QC QA Tools > Footprint Coverage Corrected errors giving slightly incorrect percentage coverage values in some situations.
QC QA Tools > Velocity Calculation Now displays the items that were written to the Access database, in the Map Legend.
QC QA Tools > Calculate Coverage Area Now gives correct cell size in output dialog when the units are in US Survey Foot
Other DoD Tools > VSP > Import Help improved to define what the parameters that are carried in the workspace.

UX-Parameter Determination Menu

Menu Item Summary
EM Data and Target Analysis submenus Tau and decay calculation tools moved from "EM Data" menu to "Target Analysis" menu.  Renamed menu items and dialogue screens for several EM tools that are specific for EM61. For example 'Check Time Gate Data' - is now 'Check EM61 Time Gate Data'.
Target Selection > Blakely Test Fixed bug where first map created with this function in a project was overwritten when re-running the function with a different GDB and GRD. 
UX-Target Management Menu
Menu Item Summary
Target List Management > Subset Target List Fixed error "Mask channel does not exist."
Target List Management > Generate Composite Target ID Now allows the user to specify the number to start numbering from (for example 1000).
Target List Management > Generate Composite Target ID Now able to read a prefix (ie. grid name) from a database channel.
Target Utilities > Target Density Calculation Modified to help better predict the total number of targets per Hectare/acre; Added foot print coverage, (i.e. how much of the area was surveyed) and correct density calculation.
Target Utilities > Target Density Calculation Corrected output report to say square metres for polygon area and area covered.
Target Utilities > Target Density Calculation The Mask channel field is no longer a Required parameter to run the GX.
Target Utilities > Shortest Path Now uses the cultural mask to indicate and therefore avoid areas that cannot be traversed.
"Move UXO Target" , "Remove UXO Target(s)", "Remove Multiple UXO Target(s)" Missing RMB context menu items restored.

UX-Analyze Menu

Menu Item Summary
NEW GX! - Interactive Image View Created a new GX to optionally view an image that is linked to a target, when clicking on a target in a view such as the scatter plot analysis or target database.  If the user selects another target the image of the new target is displayed in the same location as the previous target and the image of the previous target is removed.  This will make it easier to compare the images of different targets.
NEW GX! - Add Library Item Created a new GX to allow users to easily add items from a database of Targets or Flags to a selected Library database. 
Import Advanced Sensor Cued Data Removed the hardwired sensor height for TEMTADS and MM import and added option for Sensor height to the GUI. There is no default value for the field, and the minimum is 0.  The sensor height is used to calculate the coordinates of the sensor coils. 
Import Advanced Sensor Cued Data Now shows a warning if the new file is about to overwrite an existing line in the database.  This dialog has, in total, four options: Overwrite, Overwrite All, Skip, Skip All.
Import Targets… When importing from a CSV or GDB to a target database, the target_ID channel is created as a string with length 256 to avoid problems with additional targets created using the multifit option.
Import Targets… The time_ms channel only has improved precision
Level Advanced Sensor Data The GX previously considered all the lines in Survey and Background databases during background subtraction, which is not correct.
The correct automated process in the tool is now as follows:
1. For each target in the target database, look at the selected lines in the site database to find a line with the same number as the target ID. If no line is found, look for the closest line to the target.
2. Look at the selected lines in the background database to find the closest line to the line found in the site database.
3. Subtract the background.
NEW GX! - Decay Display - QC A new tool to display decay curves for all Tx-Rx pairs, for QC purposes.
Decay Display - QC

Two changes have been made to the GX to improve use of the Acceptance Threshold:

  1. The gate data will be set to the threshold if they are below the threshold. This will affect how the TAU values are calculated. Before this change, the TAU would be dummy if any of the two gate values were below the threshold. But now, the TAU would be dummy only when the earlier gate is less than the other one.
  2. Amplitude threshold in the interfance was replaced by Gate 1 threshold to specifically show what this threshold refers to. 
Decay Display - QC The QC decay maps are now linked to the database. If the user clicks on a line in the map, the corresponding database line will be highlighted.  If several decay curves are overlain you can click on the curve for one and have it linked to the respective line in the database so it is easy to tell which curves are the outliers, making it easier to identify problem data. 
Decay Display - QC  MetalMapper QC plots now have 2 options with both options exporting plots on 1 page.  The 2 options are 1)monostatic coils and 2) all coils.
Decay Display - QC  The Maps to plot radio button now keeps the user specified selected option instead of reverting to "All transmitters" for MetalMapper even if "Each transmiter" was selected and run.
Decay Display - Measured vs Modelled Created a new GX to display modeled data to the plot similar to decay display QC tool.  This will plot the fitted results with the raw/original decay curve.
Model Targets > Batch Mode Set the default to not use gates 0-7 for TEM and MM sensors during the modeling input dialog.
Model Targets > Batch Mode

The user now has the ability to determine if interaction will be needed/allowed, i.e. if they want to run the fitting while absent. Two changes were made:

  1. In Settings, one additional field has been added to be used for all the batch processes in UX-Analyze. It will allow the user to decide whether they want to see the error messages during the process. The default value is YES.
  2. Batch model: The error message dialog has been changed to give the user a chance to see all the error messages or skip the rest.
    Also, we log all the error messages in a log file: batch_fit.log, and inform the user that they can look at that file for details. If no error happens, the user won't see any additional dialog.
Model Targets > Batch Mode Project is saved before starting batch fitting in case the batch fitting aborts.
Model Targets > Batch Mode The "time remaining" counter has been corrected in the batch fitting which results in more accurate time estimate.
Model Targets - Interactive  Added option to turn off x,y or z coil data for MetalMapper.  Previously all data for a coil was removed if selected. When the user clicks the [Mask Rx] button, all the receiver coils will be displayed as before. When the user selects a coil, a dialog now pops up and the user has a chance to select X, Y, and Z coil to be turned off/on. This process is repeated if the user picks another coil.
Model Targets - Interactive  You no longer need to click the Display button after moving from one target to another to have the raw data/model displayed.  When the user selects a target and then the fitting button, the display will now happen automatically if the check box is selected.
Model Targets - Interactive  The "reset" button did not release the polygon mask on the raw data when displayed. The following two actions were added to the reset button in order to resolve this issue:
1. Fit
2. Display. The anomaly maps are redisplayed with the full grid or without the mask.
Model Targets  Improved population of the survey database field with the most current non-Geosoft database.
Model Targets  Automatically fills in the RX and TX channel names when the channels in the site database are called as such during the modeling input dialog.
Model Targets  If users changes target databases in the inversion dialog to a database different than the one in Settings, a database lock error no longer occurs.
Create Data Map Now sets the default gate to be the first modeled gate
Create Data Map Now have two mask channels so the user can independently control which target maps are created,  and which targets are plotted on the maps.  The first will be to determine which targets to create decision maps for, and the second mask channel determines which targets to overlay on the maps.
Create anomaly map If the starting model does not exist, it now recognizes the next number and still runs instead of terminating.
Create anomaly map Added an option "Ending Anomaly".
Advanced Target Classification Targets that do not generate a solution were giving a fit to the last item in the library.  It is now blank indicating no match.  
Advanced Target Classification The metric array channels now only display 3 decimals to reduce space usage.
Advanced Target Classification Allow advanced classification to be run in batch mode
Advanced Target Classification Now properly unlocks the array channels, to prevent error running plot polarization. 
Advanced Target Classification Active radio button is more apparent through improved highlighting. 
Create Polarization Map Now allow GX to be run in batch mode.
Create Polarization Map The parameters from the Advanced Classification now pass to the Create Polarization Map GX and are populated in the dialog screen.
Create Polarization Map Resolved a probklem where If one of the betas was negative and is not plotted, the next positive beta was plotted with the previous' respective plot color. The appropriate colour is now plotted to the correct profile when there are beta values in the negatives that cause the profile to not be plotted.
Create Polarization Map If there are multiple instances of a Target ID the GX now uses the target ID that is not masked instead of the first occurrence, for the plotted betas. 
Create Polarization Map

Function is added to check if targets have valid data in their beta channels.  If the GX runs in batch mode and some targets are blank or with invalid data in beta channels, it will log all those IDs in a text log file and display a message with the name of the log file.

If the GX runs in interactive mode and selected target does not have valid data to create map, the error icon (exclamation mark) beside the control (Target ID selection dropdown and up/down button) will show up with message.

Create Polarization Map Resolved "lock database" error from prior process (advanced classification metric calculation).
Create Polarization Map Add radio buttons for the option to output an image file.  
Create Polarization Map with Library Include option to create a map using multiple metrics.  If selected, 2 additional “metric” and “match” channels appear beneath the one currently in the GUI.  A maximum of 2 maps/metric are plotted.
Create Polarization Map with Library Resolved failures when creating large numbers of polarization  maps.  
Create Polarization Map without Library Now allows special characters in ID
Create Polarization Map without Library Font on legend is now larger
NEW GX! Create Decision Map

Created a new GX to generate a “decision plot” for each target with batch mode.  The decision plot displays images in 2 rows and a maximum of 4 columns, creating up to 8 possible windows.

The inputs include target database, group, mask, ID and channels that contain the path to the respective images such as polarization  maps, fit result plots or ground truth picture.  May place text from user defined input channels in one of the windows, such as target id, metric, rank, category, etc.  Can export an image file for each of the targets.

Create Decision Map When a mask channel is selected the mask channel was having no effect, when running in script mode.  Now only the selected targets are processed.
Create Decision Map If a data channel was added to the map and then deleted from the dialogue list, it still plotted on the map.  Now fixed - it no longer plots when deleted from the dialog.
Create Decision Map Allow user to increase resolution of the output PNG maps to 600dpi, so that details can be read when zoomed in.
Create Decision Map New GX that allows the user to easily create an analysis decision plot. 
Create anomaly map; "Export Anomaly Map"; "Export Polarization Plot" The values in the channel are now processed, starting at the "Start anomaly" value, by order of magnitude and not by the order they are stored in the channel. It will now look for the "Start anomaly" and "Ending anomaly" values (if they exist, otherwise the closest entry) and process all the entries between, and including, these two anomalies.
Populate Rank Channel If a channel is assigned when running the standard multi channel sort this channel is no longer used by the UXA ranking GX for any channels that are left blank.
ROC Curve Calculation Uses proper colour table for ROC curve.
ROC Curve Calculation The ranking is now from most likely UXO to most likely clutter.  So a rank of 1 means that target is most likely UXO and the first to dig.  Radio button added below the rank channel to indicate the sense of the rank channel. 


Please note that UX-Process and UX-Analyze require special Oasis montaj licenses, provided on request. Courtesy of ESTCP and Geosoft, these two packages are currently available to the US UXO community at no charge, along with technical support. This includes US government employees, UXO contractors and regulators working on US projects.


For technical support options, please visit the Support Centre. All users may access the forums and other resources available within the Support Community. In particular, we recommend that you join the UXOnet e-mail list, if you are working in the UXO industry. It provides occasional updates on new releases, training opportunities and other information.

Installing the software

This is a special release called a "T1" release and includes new software not yet available in our standard Oasis montaj release. Because of this it is installed separately and will not overwrite your existing (standard release) of Oasis montaj. You can switch between the T1 and the standard release by parking your license from whichever version you are currently using and then starting and entering your license code into the other. However, if you have UX-Analyze Advanced, both versions must be version 7.3 or newer.

Check your installed version

T1 releases are referred to by the build number (on the Help menu, click About). An example is 7.5.1 T1 (R3), where 7.5.1 is the standard version upon which the release is based, T1 indicates this is a special release, and R3 is the build number.

To install the latest T1 or special release of Geosoft's Oasis montaj software:

  1. Download the latest T1 version zip file from the link on this page.
  2. Park your license.
  3. Check to see if you have a previously installed "T1" version of the software. If you do, you will have a folder named C:\Program Files\Geosoft\Oasis montaj-T1\ or C:\Program Files(x86)\Geosoft\Oasis montaj-T1. If not, go to step 4. If you do have a previous T1 version:
    • Uninstall it using the Windows "Add or Remove Programs" utility.
    • Delete the entire folder C:\Program Files\Geosoft\Oasis montaj-T1\ or C:\Program Files(x86)\Geosoft\Oasis montaj-T1
  4. Extract the setup file from the zip file and double-click to run the installation process.

To use the software:

To use the T1 version, you will need to first install your Geosoft license for that version. As of Oasis montaj 7.5 you also need to create a Geosoft ID to manage your license (park etc.).

  1. Start Oasis montaj, making sure you are starting the T1 version of Oasis montaj by going to the Windows Start Menu > Geosoft > Oasis montaj T1 > Oasis montajDO NOT use any shortcuts you have.
  2. Enter your license code when prompted.
  • If you cannot download and install the software, ensure that you have Administrator rights for your computer and that you are permitted to install software. You may need to contact your I.T. department.
  • If you are not already familiar with Oasis montaj, we strongly recommend that you run through the tutorials.
Back to top