Oasis montaj 7.1

February 27, 2009

Update from Oasis montaj 7.0.1 to Oasis montaj 7.1

Release Notes

About This Release
System Requirements
New Capabilities
Oasis montaj Extensions
Oasis montaj Plus Partner Extensions
Enhancements and Maintenance Fixes

About this Release

This release includes improvements to Subsurface 3D capabilities, productivity and Esri GIS integration. The release also includes new features for replotting drillholes and importing 3D DXF files. The Geochemistry extension for Target includes a number of new features.

System Requirements

Target supports Windows XP (32 Bit) Windows Vista Business (32 and 64 Bit). See detailed System Requirements.

New Capabilities


Subsurface 3D

Working within the subsurface has become easier. Geosoft has added support for additional data formats, streamlined workflows, added new capabilities and centralized all 3D related actions within a single 3D Viewing tool.

New Supported Formats

  • The 3D Isosurface export and import functions enable you to export your 3D Isosurfaces to a 3D DXF file and import 3D DXF files into a 3D map. 3D DXF files may be displayed filled or wireframe. As DXF is supported by most 3D packages, this new capability enables you to easily share data with others.
  • The 3D PDF export now supports text. All of your text, such as drillhole labels, posted assay values and coordinate axes will be displayed on the 3D PDF view.
  • The GEMCOM Data Import supports triangulated surfaces .BT2 files, and block models .BLK files.
  • MineSight Data Import supports all the geometry elements within the MSR file type. These include markers (a set of points), polylines/polygons (connected line segments), or shells (surfaces and solids).

Improved Workflow

  • You will find all of your 3D-visualisation settings, functions, and tools in a single integrated 3D environment.click to enlarge The 3D menu has been consolidated to save you time by making it easier for you to get started.
  • You can now control and manipulate the 3D View by accessing the object and layer control tools within the 3D Viewer window.
  • You now have more control to set the background, axis, surround box and label colours for your 3D View.
  • Geosoft has improved the navigation experience by including a 3D orientation compass and a navigation cursor. 3D Viewer Navigation has an improved zoom feature to enable you to quickly go to the location of the cursor, and a series of navigation tips and other useful hints displayed on the status bar for quick reference.
  • Voxels now behave more like grids. Geosoft has made it easier for explorers to quickly access Voxel properties and metadata by adding them to the Project Explorer. As well, clicking on the voxel, will display it within a voxel previewer.

New 3D Capabilities

  • New "Open 3D Viewer" button.  New "Create a new 3D View" menu added to 3D menu.
  • New "Add to 3D" menu (consolidates all items that can be added to 3D view including surfaces, srelief surfaces, voxels, isosurface, 3D symbols, plane grids, plane vectors and drillholes).
  • Hotkeys enable quick selection between panning, zooming and rotating 3D objects.click to enlarge
  • Shadow Cursor upgrades include the ability to toggle show/hide the cursor and the cursor location is now shown in the status bar.
  • A Status Bar has been added to the 3D Viewer. The Status bar displays the view's coordinate system, the shadow cursor location, the view's inclination, declination and look-at point (center of rotation).

Enhancing Productivity

The following were designed to improve your workflow and productivity:

  • New quick link to Geosoft colour tablesclick to enlarge and colour files in your working directory. A simple toggle allows you to browse to your project folder to load your ITR or ZON file.
  • New array to database channel capability allows any selected number of array channels to be displayed as regular channels. This is a very efficient way to display a large number of array channels.
  • New profile scaling optionsclick to enlarge: The Profile Views have been updated to provide clearer scaling options for the X and Y axes when changing between lines.
  • New map extents: You now have the ability to interactively define the extents of a new map, using your existing map.  This is designed for creating new maps of targets or creating small scale field maps from regional map views.

GIS Integration

Importing Shapefiles

When importing shapefiles you now have the option to save the coordinates of polyline or polygon entity nodes in a separate database.

Support for ESRI projections

Geosoft now fully supports all ESRI projections and Datum transforms.click to enlarge When importing ArcGIS shapefile and layer file data to Geosoft Maps and MXD files, explorers can easily reproject using either Geosoft or ESRI transforms. When using ESRI transforms, the dialogs maintain the ESRI look and feel to provide a natural experience.

This new process ensures that when ESRI data types are utilized in the Oasis montaj environment, location accuracy is maintained and the user controls the datum transformation process at each step.  This process is carried though to DAP where the same new reprojection dialogue will allow users to access and control the ESRI datum transformations being applied to downloaded ESRI data formats.

Updates for Oasis montaj software extensions

Depth to Basement

Users can now display all solutions with same Y scale and range


  • Replot Holes on Plan/Section: The replot holes on plan and section maps option enables you to regenerate your current plan or section maps without eliminating any groups that have been added in, such as interpretations, images, or grids.
  • Importing 3D DXF files into Sections: plots the intersection trace of a 3D DXF on the section.


  • Geochemistry classification diagramsclick to enlarge have been added to the Geochemistry system as templates for triplots and scatter plots. The templates are grouped by category: Lithological Discrimination and Diamond Exploration.
  • The Geochemistry SEMPlot tools have been updated enabling explorers to export "selected" raw or processed data to a new database. Also, you can now modify the symbols and/or colours for multiple samples at one time.

Geophysics Levelling

The new Iterative Leveling optionclick to enlarge enables explorers to optimize the identification and correction of errors in geophysical data. The option repeats the process of leveling ties to flight lines, then flight lines to ties, until the process converges.

GM-SYS Profile

The GM-SYS Profile enhancements include the following:

  • There is a new Display Elements dialog enabling users to toggle multiple display objects at once
  • Users can now calculate and export the gravity field on a vertical section grid coincident with the model section
  • Users can now export an oriented, vertical section grid of a model property (density, susceptibility, velocity)
  • Geosoft added "View" buttons to main toolbar (Add/Edit/Previous View)
  • Added a warning and code to prevent an imported horizon with self-crossings from being incorporated into the model
  • GM-SYS errors are now passed back to Oasis montaj when opening and building models fails
  • Users can now hide the Action toolbar when the Import Horizon dialog is active
  • The IGRFPT utility supersedes the NGRF function
  • Added support for building time models from grids and databases
  • Added support for importing time horizons to the ImpHoriz button on the main toolbar

SEG-Y Reader

SEG-Y Readerclick to enlarge has been significantly enhanced with separate workflows for 2D and 3D SEG-Y files.  Users can create an index database of trace locations that allows flexible masking of traces by inline/cross line, with polygons, with header flags, and/or by individual traces.

Traces can also be windowed and/or decimated by time (or depth).  The SEG-Y Reader can now import much larger files, up to 2 billion traces, and can export voxels containing up to 3.3 billion cells.


The GM-SYS 3D enhancements include the following:

  • Projections are now saved in the model file
  • The model now gets the horizontal & vertical units from the projection
  • Users can now calculate the gravity and magnetic response of a voxel when no GM-SYS 3D model is open and calculate the gravity response inside a voxel
  • The Joint Inversion dialog has been redesigned and streamlined
  • Most dialogs now treat [ESC] as [Cancel]
  • The cross section extraction tool now names layer boundaries from the source grids, instead of "layer #" in the View/Group Manager
  • The detrending of pre-expanded grids has been improved
  • Layer piercing during inversion is more robust

Gravity and Terrain Correction

We have modified the Scintrex CG-5 Gravity Meter dump file import to include the Standard Deviation (SD) column, used to assess the data quality from all stations.

Induced Polarization

  • Geosoft has added the UBC 2D Model Import - This enables explorers to convert UBC 2D model files to a Geosoft grid file and display them on a map.
  • UBC IP export is also now available, enabling explorers to export RES or IP data for use in the UBC inversion program.

MAGMAP Filtering

Interactive spectrum filterclick to enlarge The interactive spectrum filter now displays the wavelength units rather than the wavenumber. Also, the display range on the spectrum view can be modified to provide detailed examination of the long wavelength portion of the spectrum.

Oasis montaj Plus Partner Extensions

PotentQ 4.10.01

With this release PotentQ supports multiple bodies. It is now possible to create up to two ancillary bodies that can be used to model the spurious observations, thereby leaving a clean residual to model as the main anomaly. Previously, PotentQ allowed only a single body to be used in the model.

Predictive Targeting with Neural Networks

The Predictive Targeting with Neural Networks software has been improved with an easier to use interface and a new neural network engine.

Praga4 - version 1.1

The interface has been redesigned to provide a better and more efficient user experience. All controls have been logically grouped and are context sensitive for the current selected method (i.e., interactive and processing modes). In addition, users will find it easier to select the appropriate project mode (i.e., airborne and ground survey modes).

The IAEA standard method of radon removal using upward-looking detector has been added to Praga4 functionality. To improve efficiency, the Spectrum ratio method can now use NASVD restored spectra even with raw spectra in the input.

Enhancements and Maintenance Fixes

Oasis montaj

5672 Improved handling of SHP files imported to GDBs
8637 Improved access to colour TBL files in folder and working directory
8995 Added  set output resolution from script as DPI in expmap.gx. 
9483 Corrected ABORT <CGeoProject::sRunContextMenu_GP> during save all on program exit.
9698 Selecting a View does not change in the Map View/Group Manager 
10442 Could not view the Manuals/Tutorials by going to Help >> Manuals/Tutorials if you have Mozilla (Firefox) as you're default browser
10669 Oasis will not run unless ArcGIS hardlock is inserted into the computer. 
10818 Corrected ABORT <sDummy_VV> - running grregter.gx
10963 Corrected  ABORT <sMarkItem_MGROUP>  while adding text to a map
11054 Fixed the exporting a CSV file with a TIME channel, and re-importing the TIME channel from a CSV file
11086 Added option to define X/Y extents of a new map interactively from an existing map
11290 Corrected ABORT <CVU_Cell::OnRButtonDown> when downloading acQuire data and then merging two databases and discarding the changes
11489 Fixed the path stored incorrectly in the "project"
12053 Corrected ABORT <thin2_> when attempting to contour a large grid.
12078 Corrected <CVU_Cell::OnRButtonDown> when importing a GDB created by exporting feature data from Profile analyst.
12112 Fixed adding a 3D DXF to a 3D map. Does not go to the proper surface and/or cannot draw groups from a 3D view onto a surface in a 3D map
12121 Fixed creating section grids from array channels require 3D orientation
12266 Fixed error when gridding voxel: "Run failed because Cannot interpolate data because it is not a function. The X VV either backtracks or repeats."
12284 Corrected ABORT <Check_REF> - Opening a map document with a 3D inversion model.
12396 Corrected ABORT <sTraceCalcDH> when using unsorted assay values
12973 Corrected ABORT <vSmooth2_CONTOUR; thin2_> - Generating contour map. "Unable to locate error message 7638 in the GER files"
13008 Fixed refid error (using nearest interpolation) on a database (with ARRAY data) using a distance channel, those arrays starting with dummies are not copied
13017 Fixed profile.gx error when "smooth line" parameter set to yes: "Cannot interpolate data because it is not a function. The X VV either backtracks or repeats."
13038 Corrected ABORT <sSetVV_ERMXGD> - trying to export map as ecw
13126 Corrected ABORT <Memory Leak. The MP Object was destroyed while not empty>
13159 Fixed 3D tool being too large.  The new 3D tool requires too much screen space and is it not scalable.
13160 Fixed - Warping/geo-referencing a JPEG image produces odd, skinny resulting colour grid
13165 Fixed problem with some colour tables that don't seem to plot properly in 3D Colour Range Symbols
13292 Fixed error - Trying to create a map of the world in lat/long using a Robinson projection, when creating base map get error: "Unable to determine lat/long values for map corners. The range in XY may be greater than the valid range allowed.."
13385 Fixed - Unable to use Import an ASCII Grid with an ASCII file with lines >32767 characters
13475 Fixed - Minimum Curvature in v7.0 doesn't seem to be honoring the Cells to Extended Beyond parameter in the Advance Options in some cases
13512 Fixed Installation - Splash screen appear then disappears and OM doesn't open. OM won't open.
13521 Fixed- Some users with limited computer rights cannot write to certain Geosoft folders, and thus some functions do not work
13559 Fixed error messages on Vista: "Georefresh has encountered a problem and needs to close"
13596 Fixed grid outline issue on some grids
13618 Corrected ABORT <hCreat_GEO3D> - Importing sections into a 3D viewer, one at a time.
13619 Fixed - Colour fill on a complex multi-layer PLY group is changing on its own.
13640 Corrected ABORT: <hCreat_GEO3D> Exception: GEOLIB AbortCode=5B61498 and 3D viewer error message: "Error in function wglMakeCurrent because [Unknown]".
13650 Corrected ABORT <lLineVV_GDBRLN> - Trying to grid data using minimum curvature
13653 Fixed - OM cannot import MapInfo 9 TAB files. Results in the following error message: "MapInfo error opening ".\Oquirrh Surface Samples_MI90.TAB"
13668 Fixed -  Cannot delete a line from a single line GDB. If you select the line and press delete nothing happens.
13676 Improved clarity of required channels on New Projected Coordinate Tool
13704 Fixed - Problems with section extractions from a 3D Voxel, the section grids are not honouring the line ends requested
13745 Fixed- plotting a section containing Layer files (*.lyr) in the Plan View to a PDF the layer files are left out of the PDF
13751 Corrected ABORT <sLongValuetoIndex_ITR> - using gridimg1.gx
13760 Fixed error exporting to TAB: "MITAB Library error for file C:\xxx.tab: Some objects were written outside of the file's predefined bounds. These objects may have invalid coordinates..." Cannot export masked groups to TAB (they appear as unmasked)
13841 Improved error messages when using gridmask.gx, when the ply file is located in a different directory from grid to be masked.
13844 Fixed - problem with the coordinates selected when drawing a Rectangle PLY File on a rotated grid
13859 Fixed - plotting contour control file error: whensuing LEVOPT of -1
13874 Fixed - The curser location in database profiles seems to lag the highlighted row in the database,
13879 Corrected ABORT <sReadLTB> -opened a GPF and tried to cancel the drawing of a 3D map.
13924 Fixed - the Ruler and Protractor tools renamed
13935 Corrected ABORT <FindAndDestroyESRITransparencySlider> in 3D tool
13939 Fixed - Exporting a map group (of polygons) to a PLY file using groupply.gx, polygon offset
13952 Corrected ABORT <sSymbLST_DB> - copy points from one map to another map
13966 Fixed - GDB Profile data is masked in the wrong location
14002 Corrected ABORT <sColorIndex_ITR>  displaying profiles with dummy values
14003 Corrected ABORT <sColorIndex_ITR> - trying to display Profile or Section Colours to an array channel
14005 Fixed - import a large ASCII grid with 5000 X 5000 points: "Too many points at line 3 in the file". Line width (character) limit of 32000
14015 Fixed - Using an import template, importing an XYZ with array data. Replacing a value with dummy, not working
14039 Corrected ABORT <sGetESRIIPJ>
14042 Fixed confusion of "Log" (in rangrid GX) vs "log-linear" (in krigrid)
14069 Corrected ABORT <GENSURF::pLoadVBO> in 3D viewer
14077 Fixed - Toolbar position causes Oasis montaj to freeze
14089 Fixed - USGS grids and projection issue. USGS PC and USGS Unix grid headers should not be modified when the projection is set in Oasis 
14164 Corrected ABORT <Destr_ERMXGD>
14174 Fixed - using gridmask.gx (windowing a grid based on a polygon PLY file) - if the first and last lines of the PLY match exactly, the resulting windowed grid is incorrect
14182 Corrected ABORT <sGeneralFileFormExt_GUI>
14197 Corrected  ABORT <sSetITRPercentiles_DB>
14261 Fixed - 3D DXF import error message: "X and Y extents defined in the Header section of the DXF file are incorrect".
14277 Fixed - Copy/Convert Geosoft Voxel to UBC - output file should not just say UBC MSH, but also MOD
14293 Corrected ABORT <UserMeta::GetGeoLineage> <UserMeta::Create> writing XML files, export ECW
14337 Corrected ABORT <sOpenChange_SMETA>  adding a voxel to a 3D view; attempting to make the existing relief surface transparent
14371 Fixed - voxel math expression error "This voxel must overlap with all other input grids/voxels", but the voxels do overlap
14383 Fixed - Can't run polygeo.gx any longer without an active map
14395 Fixed – Projection dialogue: orange star beside projection drop-down dialogue item should not be there if specifying unknown or geographic (lat/long) projection.
14418 Fixed - Ability to turn on/off the screen door transparency for users with ATI video cards
14430 Corrected ABORT <Free_MP> - running polyregen.gx without an open map, or without running polygen.gx first
14438 Fixed - 7.0.1 - cannot grid separate array channels anymore as textbox is locked on dialog box
14446 Fixed - Exporting selected channels from GDB to CSV, no matter how you organize them, the results are always ordered alphabetically
14448 Fixed - Printing and map display bug - EMF files of text (imported from a Word DOC)
14469 Fixed - math expression won't work in v7.0.1 using the Channel Math tool in some cases
14470 Added ability to create isosurfaces of 3D DXFs, 3D SHPs, 3D datamine files
14487 Fixed - importing a SHP file to current database with script, asks for .gdb instead of just importing to current GDB
14490 Corrected ABORT <sGetInfo_ST>
14493 Fixed - error message: MAPPLOT control file error at line: 20 in file: _basemap.con. Problem with dragging groups from a map made using newmapll.gx 
14496 Fixed - OM 7.0.1 Manuals and Tutorials: Unable to launch PDF manuals and tutorials when IE 7 is set as default web browser.
14504 Corrected ABORT <ReadBlob_MM; [MM] Unable to page virtual memory: The operation completed successfully>
14557 Corrected ABORT <sDatFileFormEx_GUI>
14580 Fixed - Can't run a channel math expression through a script unless the channel has already been created in the database
14587 Fixed – OM Export to 3D PDF, the axis are not exported.
14682 Fixed - Geotiffs created in OM are not displaying correctly in MapInfo
14685 Fixed - Can't import a USGS (*.*) SG grids. Coming in as GRD(USG) instead of SG(USG). Error: "Invalid field value "\nzs_predg.GRD(USG)" in the "Grid name" field. This value must be an Existing File."
14687 Fixed - Change the location of the temporary file directory, but it does not stick. Reverts back to default (or last saved directory path)
14713 Fixed - Exported a map to DXF, opening the DXF in AutoCAD & GOCAD, the DXF is misplaced (in the wrong spot in AutoCAD/GOCAD) in some cases
14770 Corrected ABORT <AbortCode=NHX9M3X - Assertion Failed - m:\r701\src\class\mt\mte.c {765} >
14774 Fixed - Database Profile Panels are having a hard time displaying profiles from channels which contain exponents
14798 Corrected ABORT <CGeoProject::sRunContextMenu_GP>
14850 Fixed - LOOKUP2 GX. Date time lookup functioning incorrectly.
14864 Fixed - search/replace does not work if string value in cell excedes 19 characters
14873 Corrected ABORT <sImportAMIRA_DU> , Assertion Failed, AbortCode=6K1WF6X, attempting to import an AMIRA file.
14875 Fixed - Incorrect Datum and Datum Transform applied to MapInfo TAB files downloaded from DAP server
14909 Fixed -  Ambiguous local datum transforms, two LDTs have the same name.
14911 Fixed - export to DXF Improper table entry name CATRIEL REGULAR, Invalid or incomplete DXF input -- drawing discarded
14912 Fixed - IGRF.GX - "SetFidIncr_VV: Invalid Fiducial Increment" - Error message occurs when running the IGRF correction GX on a GDB.
14944 Fixed - profile panel, highlighted point does not match black box that is centred on fiducial
14948 Fixed - Unable to adjust the Line Thickness parameter when plotting Lat/Long annotations using crosses
14949 Fixed - projection information being read incorrectly for tiff file in some cases
14975 Corrected ABORT <hCreat_SELMON>
14976 Fixed - IMPORTBB i2 file isn't resulting in the right line number in some cases
14978 Corrected ABORT <Free_MP> - TINDB massive data set
14990 Corrected ABORT <sReSurveyEastNorth_DH> 
14991 Corrected ABORT <lRecords_LTB> - When ever attempting to open or create a new project the program crashes
15049 Fixed - Problem when selecting degrees in atan calculation in channel math gui, only calculates in radians
15059 Corrected ABORT <AbortNowThreadSYS m:\r701\src\class\sys\stacksys.c {932} AbortCode=HAW51M5 >
15065 Corrected ABORT <GetLocalParameterName_GS> exporting map to ECW
15068 CorrectedABORT <sLoadGravity_DU> - importing Geosoft RAW format with incorrect DMS parameter
15072 Fixed - changing fill colour of low tick hachure marks
15103 Corrected ABORT <GetRelLocalName_GS> - after exporting 2 contour layers to Mapinfo tab format, then 2 images to ecw format 
15104 Corrected ABORT <UserMeta::LoadIso> - windowed a series of larger grids and this was the 5th ecw export when it crashed.
15150 Fixed - Activating a Data View does NOT make it the active data drawing view.
15151 Fixed - Array channel displayed with array colour sections in the channel cell are not saved.
15173 Added ability to plot a colour legend bar for a voxel
15183 Fixed - Orient an ECW image and use the top left corner as the Reference Point it looks good in 3D. But when you display the image in 2D it’s displayed incorrectly. Inverted and backswords.
15273 Corrected ABORT <sEquivalentPercentile_ST>
15275 Corrected ABORT: <sSmpLoopN_SYS> Assertion Failed : attempting to display a large Voxel (>400MB) in 3D
15276 Corrected ABORT <sThin2D_VV>
15295 Corrected ABORT <GetRotation_3DN> - Ab. prg exit when attempting to rename a 3D group when the 3D viewer is still open.
15297 Corrected ABORT <dDirection_DU> seldir.gx
15401 Fixed - "My Computer" list empty when browsing to locate a file to which the link in the gpf has been lost
15483 Fixed - Automated map sheets not selecting properly in preview when more than 26 columns
15667 Fixed - DXF exported from OM is appearing empty in AutoCAD 2009
15732 Corrected Abort <hCreat_GEO3D> when changing transparency of a grid in a 3D map
15885 Fixed - The wrong projection parameters are getting displayed when creating a new projection using the New Projection Method window. (Lambert Azimuthal Equal-Area)
15886 Fixed - When creating a new projection method using Lambert Azimuthal Equal-Area as the projection type the transform.csv file is adding Latitude and Longitude of false origin even when values are set to 0.

Oasis montaj Extensions

montaj Drillhole
4761 Added - Linking between the Scatter plot tool and database 
7667 Added ability to refresh holes group without replotting the entire map
7859 Fixed - importing assay data from XLS spreadsheet the first dialog shows you two options under the Database Table drop down, but there is only one sheet in the XLS
9259 Corrected  ABORT <GEOSTING_SFLASU> <AbortNowThreadSYS>  when replotting strip logs, recreating a cross-section
10094 Fixed - Preserving polygons when recreating sections. Copy and pasting groups layers from section to section.
10614 Added ability to view a 3D DXF file in a section view, clipping the DXF extents to the section width - currently the entire DXF is displayed.
10952 Added ability to define multiple section locations using a offset distances and thickness
11052 Fixed - Exporting a map to 3D DXF file - these files cannot be opened in AutoCAD or in GOCAD. Error: "Undefined group code 2 for object on line 1592."
12042 Added ability to preserve geological interpretations (or other added layers) once a section or plan map is regenerated
12144 Added ability to plot the projection of an isosurface onto a drill hole plan or section
12458 Added ability to export isosurface to a 3D DXF.
13309 Fixed - Strip logs you can only plot the scale bar at the start and end of a hole
13615 Fixed - DHLASIMPORT GX DHIMPORTLAS GX: LAS File Import: Negative depth readings are not read in by Geosoft import (correctly)
13649 Fixed - Fence Diagram map - Zoom to full extent and you do not see the proper colour fills
13659 Corrected ABORT <VOXSURF::pLoadVBO> - opening an old project in v7.0
13671 Corrected ABORT <Destr_GEO3D> - displaying/working on a map and importing Excel data
13737 Fixed - Closed polygon export to 3D DXF, re-imports as a polyline group.
14028 Corrected ABORT <CVU_Cell::DrawData> - changing the selected drillhole and changed the name of the hole in the survey, collars and lithology to remove a hyphen
14379 Fixed - Limit on the amount of available space for plotting the Rockcode legends. You can only display 16 rockcode with their respective codes and description  ockcode the legend default to the code only.
14382 Corrected ABORT <sGetSectionLocations_DH> - trying to plot a section map with a profile
14410 Fixed - Plotting multiple profiles on a section map don't get plotted because the group names are overwritten
14445 Fixed - Strip log compositing fails when some data are not plotted in the strip log map.
14506 Fixed -  Cursor disappears when defining a section/plan location on Vista OS
14507 Fixed - Problems when tracing stacked section locations on a plan map
14578 Fixed - OM Drillhole LAS import will not import any data where scientific notation is used.
14579 Fixed - Drillhole LAS import remove/convert null values from data as specified by the null value in the file header.
14581 Fixed - Drillhole LAS import; does not read the both the possible name fields from the LAS header. Should read both Well and UWI.
14725 Fixed - Striplogs. "NUMBER BANDS" text is getting placed behind the Bar Plot legend when plotting an ASSAY channel using a colored Bar Plot with a Zone File.
14803 Fixed - LAS Import dummy value +/-999.25 necessitates search\replace for Geosoft dummy (*), which leads to overwriting of VALID data
14804 Fixed - Import problem with csv files, data start row not recognised in some files
14810 Corrected ABORT <VOXSURF::pLoadVBO> Trying to add Voxel to 3D map, also trying to create isourface, and GoCAD to 3D
14863 Fixed - string classified symbols don't get plotted properly if over 19 characters
14872 Corrected ABORT: <AbortNowThreadSYS> Exception: EXTTOPOENGINE , AbortCode=HAW51M5
14892 Corrected ABORT <sImportGeoXML_IPJ> - Unstable project
15003 Fixed - PlotFenceSection GX.net: Well elevations are plotting at DH_Top rather than DH_RL
15066 Corrected ABORT: <hHoleSymb_DH> Assertion Failed: attempting to calculate composite of an interval of a drill hole
15107 Corrected ABORT <CPageSurfaces::ChangeSurfaces> - no info
15128 Fixed -  Extend drop down box for string plotting option in 3D Drillhole Data tab, Rock Patterns are off the bottom of the list.
15193 Fixed - DHIMPORTLAS.GX - Importing a LAS file which contains a column that has negative and positive values results in a channel which only contains positive values.
15201 Fixed - Target Databases with a space in the name are not selectable in the Data tabs of DH Plot.
15202 Fixed - Draw Holes on Any Plan doesn't work for my surface geochemistry map.
15265 Fixed - 3D Legend does not work properly for structural data plots
15333 Corrected ABORT: <GetAtt_MVIEW > : Assertion Failed:m:\r701\src\class\mview\grpmview.c:  Creating a fence diagram
15426 Corrected ABORT <sListAllDocuments_GPOBJ> Right-clicked on database in Project Explorer, then "Properties"
15526 Fixed- Weighting channel setting in composite database dialog can't be cleared
15603 Fixed - DXF exported from Target section gives error: Failed to convert the characters on line 12785 of the DXF file S567749EC188-C197_New_SSt Alt Zones into an integer or float value.
15814 Fixed - strip log scale axis does not plot in the correct position
montaj Geophysics
4205 Added ability to integrate UBC inversion data
13332 Fixed SEGY v7.0: "System out of memory" exception while writing large file to GDB.
14374 Corrected ABORT <SMPThread; AbortNowThreadSYS> - attempting to save a 3D SGY to a Geosoft 3D voxel
14381 Corrected ABORT <Exception:  WriteTrace3D_PG : Invalid Column> - reported invalid column at the end of saving from SEGY to 3D grid
14387 Corrected ABORT <Exception: Index was out of range. Must be non-negative and less than the size of the collection.> when exporting SEGY to Voxel
15529 Fixed - CDI to ribbon plots displays an OK prompt for every line when removing backtracks
15631 Fixed - 3D SEG-Y Index Database Creation Error: 'Object reference not set to an instance of an object'
montaj Induced Polarization               
11070 Corrected ABORT <sResixZonge_IP> - Attempting to run IPRESIXZONGE.gx to invert res/IP data
13846 Fixed -  Importing IPRED12 dump file. Error messages: "error importing Scintrex IPR-12 ...line13...time window values were expected, not found in file...", "error:  reading file, error extracting line direction - must be one of N,S,E,W", 
14388 Corrected ABORT <sMaskPruneVVIP> - using ipgridn.gx and ipxy.gx
14607 Fixed - plotting an IP pseudosection with more than one major/minor contour level defined reports error: "Error reading control file ipcont.con on line 12. The LINTYP value 11 is not in the permissible range of 0 to 6."
montaj Magmap
9847 Added - replace all occurrences of "wavenumber" with a distance measurement
11783 Added ability to zoom in on left end of spectrum display in MAGMAP interactive tool 
14790 Fixed - Cannot delete 2nd filter in FFT2CON
montaj Gravity and Terrain Correction               
4977 Added Standard deviation channel to import of CG5 and Geosoft RAW format files
13921 Fixed - error running Drift correction: "Field 'Instrument' could not be found in the lookup data table"
14036 Fixed - Treatment of station numbers greater than value 90000 on Geosoft RAW import, are not recognised as basestations.
14064 Fixed - GRAPPEND GX: Overwriting an existing blank master gdb, the gdb is not re-written\created, (if it already exists, or listed in Project Explorer)
14079 Fixed - GRBOUG GX: Calcs use generic formulae from .lst files, regardless if user-defined formulae specified or not
11945 Fixed - Inconsistency in how we import R61 and M61 files, with respect to how we position the GPS data with EM61 data
13150 Fixed - UX-Process UCE Velocity - symbols are too small/ not clear
13282 Fixed - uceimport.gx if the gdb name is changed during the import, the gdb is created, but no data is imported.
13427 Fixed - UCEdrift median filter does not function.  It appears that the channel displayed as the median filter is not the residual, just the running median.
13472 Corrected ABORT <sBaseMagCorrection_DU> - I am following the "Base Station Correction" steps in the UX-Process tutorial, using the tutorial data when the system aborts.
13690 Fixed - 6linetest, Increase the line colour contrast. Change the yellow & cyan over the "line with object" to red and green or blue.
13765 Fixed - " Attempt to access CHAN Symbol [Northing] failed because the symbol was not locked for READWRITE".
13800 Fixed - UCEPOSITION (UX-Detect) Error message: "AxisY_MVIEW: Invalid Vertical (y) bar range."
14061 Fixed - Signal strength, SNR, and size - when you press tab, it skips the Target GDB and then the Target ID. As well, if you enter values into the Signal width, your background and noise values are automatically deleted
14613 Fixed - ucevelocity.gx. Add ft/sec to the velocity drop down list.
14618 Fixed - ucewindowstats, the text statistics file is generated  but not opened.  Inconsistant with the statistics GX.
14619 Fixed -  ucecalibrate, Does not remember the last database. Does not take current databse as default.
14629 Fixed - ucepipeline, it asks for the line spacing if it is not in the workspace.  It should just leave the entry blank, and let the user fill it in the main dialog.
14631 Fixed - uceimport, Remove entirely ucer61adjust.
14633 Fixed - uceimport, Remove the download GXs
14641 Fixed - ucecalibrate, change "Instrument threshold" to "allowable  failure %".  Move "allowable.." down to "Channel selection" group.
14643 Fixed - ucecalibrate, The static noise master database remains the current databaase after the process is complete.  Make the input GDB the current one upon exit.
14644 Fixed - ucewindowstats, the name of the output file is inconsistant with statistics.
14647 Fixed - uceemtauconst, erroneous title calculate time constant instead of decay curve.
14670 Fixed - uceimport, R61 file, why does it generate raw_x & raw_Y. 
14671 Fixed - uceprove, can not select a group.  Multiple groups causes erroneous results.  Allow proper usage of multiple groups.
14754 Fixed - ucefillgaps.gx, the legend is projected in meters not us survey feet as it should be.
9632 Fixed - produce density section grid from a model that is correctly oriented in 3D
13070 Fixed - Show the real coordinates in status bar
14390 Fixed - Plot, Save/Load Config File, is inconsistent in that is does not store all the settings.
14588 Fixed - can't load SGY file as backdrop, but are licensed to use SEGY Reader through Geophysics license
14812 Fixed- NGRF program, Update available for (16 bit) NRF.exe? Running Vista\ XP Pro 64 bit
15074 Fixed - Create a new model change cross ection units for Z from km to m, when click "add flat horizons" button, all of the layers have a depth of 12800000000000000000
15089 Fixed - GMSMARK,GMSPROF:  Can't deselect items in drop-down menus if you want to specify a constant value instead.
15143 Fixed - XYZGMS:  All dummies in any (grav) gradient channel prevent any components from being written to the model.
15177 GMSYS - Group move in Time window causes abort.
15991 Corrected ABORT <sFindConvexHullTIN> trying to convert a GMSYS 2D time model to a depth model when the crash occurred.
16069 Fixed - Grid lines do not draw correctly in some models
GM-SYS 3D          
14007 Fixed - GMSYS-3D Structural Inversion moves past non-piercable grids in a complex model
14429 Fixed - GMSYS 3D bug - using ngagrdmch.gx (Make Grids Coincedent) - the output grid contains a lot of dummies that shouldn't be there
GM-SYS Depth to Basement
12252 Corrected ABORT <sExecute_GX> EXEULER GX - clicking ok on dialogue
12283 Corrected ABORT <sExecute_GX> - after having installed the matlab DLL's and trying to run PDepth > Euler Solutions (exeuler.gx). Before abort, had :"Error opening nga_ee.dll" and "Check path to Matlab dll's"
13059 Fixed - ErrorMsg when running CLUSTER.GX: "LockSymb_DB : Invalid Symbol Lock"

Oasis montaj Plus Extensions

PGW - Compudrape
13869 Fixed - Compudrape - drape1d.gx - output channel is filled with dummies. Problem - existing distance channel is empty and drape1d.gx is not overwritting it
15470 Fixed - VARYRTP.GX - Error message running the Continuous RTP function on a grid which crosses the 180 degree longitude line. "Calc_IGRF : Invalid Longitude value".
PGW - Predictive Targeting
14819 Fixed - error and problem with PGW Predictive Targeting and Neural Networks - cannot produce an XYZ file using nntrain.gx, and error creating GDB using nnsim.gx: :"Abort: cannot process input grids with unequal sizes or KX"
13073 Corrected ABORT <sExecute_GX; PRAGACORE; GEOPRAGA: The thread tried to...> - Starting Praga 3; trying to switch from NASVD to MNF view mode
15399 Fixed - After creating a Praga3 project the default grid location becomes ...\_PRAGA_PROJECT. If you exit the project ansd reopen a map OM cannot locate the grids store in this location.
Back to top